AI Adsense

Thursday, November 07, 2013

Exchange SP2 Install Error: This Server Role Can't Be Installed Because the Following Roles...

Mailbox role
Error: this server role can't be installed because the following roles aren't current: AdminToolsRole MailboxRole
Here's the fix for it:
Open REGEDIT
1. HKLM\Software\ExchangeServer\V14\AdminTools\ConfiguredVersion
Change ConfiguredVersion from 14.1.218.5 to 14.2.247.5

2. Repeat this process for the other keys labeled TRANSPORTROLE or MAILBOX role as needed.  The different versions on those numbers are the source of the problem.

3.  Restart server and then start Exchange 2010 SP2 setup again.


Good luck!

No comments: